NTS Forums

Please login or register.

Login with username, password and session length
 

News:

Welcome to the Newtek Technology Services Forum!


Author Topic: Migration failure going from ColdFusion 9 to 10.  (Read 4908 times)

Offline maplegate

  • Jr. Member
  • **
  • Posts: 146
  • Karma: +5/-0
Migration failure going from ColdFusion 9 to 10.
« on: May 16, 2013, 10:32:39 AM »
Yesterday I tried to migrate a site from ColdFusion 9 to 10, and it failed right away.  I have searched here and at Adobe, but cannot find any reference to this type of problem after the migration.

After the site was moved to CF10 it had and failed, I deleted and recreated the datasource name and the 1 mapping used by the application.

I then wrote a small program which progressively added CF features.

Doing <cfdump> of APPLICATION and SESSION showed the app/session were starting as intended.

Doing a simple inline cfquery and <cfdump> of the recordset showed I could reach the database.

But attempting to <cfinvoke> a method in a CFC (which is referenced by the CF mapping) failed with a plain 500-level "server error", with no more details.

I don't know whether the problem was in the <cfinvoke>, or whether the function could not execute the query (the same one as in my test page), or it could not return the recordset.  [Except that the query is in a <cftry> block, so I would hope an error there would have been trapped].

Since we move the site back to CF9 after a few hours of down time, CT tech support closed the ticket and stopped their research.  But there's clearly either a fundamental configuration problem, or a piece of my application code which exhibits a a major incompatability with CF10.  Until I know which, I am obviously reluctant to try migrating other sites.

Has anyone experienced anything like I describe after a migration to CF10?

Thanks....
-don

Rick C.

  • Guest
Re: Migration failure going from ColdFusion 9 to 10.
« Reply #1 on: May 16, 2013, 11:55:28 AM »
Can you PM me some domain details? I'd like to look into this.

Offline morovan

  • Hero Member
  • *****
  • Posts: 1,052
  • Karma: +54/-2
Re: Migration failure going from ColdFusion 9 to 10.
« Reply #2 on: May 16, 2013, 01:36:40 PM »
Support should be able to suppress the 500 error so that you could see what was actually happening.  May be a relatively simple fix once you see what CF is choking on.  With that said, I have moved a lot of code over with little to no changes.
www.todayrealestate.com - Search the MLS for all properties for sale on Cape Cod, Massachusetts.

Offline Seraphic

  • Hosting Newbie
  • *
  • Posts: 2
  • Karma: +0/-0
Re: Migration failure going from ColdFusion 9 to 10.
« Reply #3 on: July 10, 2013, 01:40:28 PM »
I know this is late in the conversation, but someone else may run into this so here is my 2 cents. I always have trouble with error 500's on the servers because debugging info isn't spit out like it would be on your own dedicated server telling you exactly what the error is. So  this might work for your issue, it did for mine.

In my application.cfc in the OnError function, just catch the exception and email it to yourself. It takes slightly longer to debug because you have to wait for the email but it did work for me while I was writing a new app. Technically you could just output the exception on the page, but since my site was live and being seen be people I didn't want anyone else seeing what I see. but if you wanted to, you could skip the generic message to show users and just move the cfdump to that part.

<cffunction name="OnError" access="public" returntype="void" output="true" hint="Exception occures that is not caught by a try and catch.">
       <cfargument name="Exception" required=true />
        <cfargument type="String" name = "EventName" required=true />

        <cfif Find("coldfusion.filter.FormValidationException",Arguments.Exception.StackTrace)>
            <cfthrow object="#exception#">
        <cfelse>
            <!--- Generic message for anyone who encounters an error. --->
            <cfoutput>
            <div>
                An application error has occured. The webmaster has been notified.</a>.
            </div>
            </cfoutput>
            <cfmail to="you@yourserver.com" from="you@yourserver.com" server="mail.yourserver.com" subject="Application Error" type="html">
                <cfdump var="#exception#" label="Error Details">
             </cfmail>
   
        </cfif>
      <cfreturn />
    </cffunction>

Offline paulmoment

  • Hosting Newbie
  • *
  • Posts: 1
  • Karma: +0/-0
Re: Migration failure going from ColdFusion 9 to 10.
« Reply #4 on: August 03, 2013, 12:47:31 PM »
I'm having no end of trouble with CF10 shared hosting. I've been going around and around with Support for two weeks on a simple move of some sample code from CF9 to CF10. This is code that worked without hitch moving from CF7 to CF8 to CF9.

I had one tech finally track down the issue to a permissions mis-adjustment in CF10 administrator which I believe had something to do with CF not having r/w/m/d access to files and folders in the web root for my domain. (I asked the tech to document what they did, but apparently that didn't happen.) And once I moved stuff around in the directory, suddenly it all stopped working again. I finally had the new tech on my ticket move my site to a different CF10 server to see if it was just some kind of stuck configuration thing. No dice. The tech just kept telling me it was a problem with my code.

So I stripped it down and tried a test. Here's how I detailed it to Support:
------------
The CF10 setup seems unable to execute even the most basic CF include functions.

For example, I have only three files in the root of  http://216.119.114.163/ :

Application.cfc : Stripped down to the most basic CF component information.
index.cfm : includes one line of text and one cfinclude to…
_test_include.cfm : a simple text include file with only one line in it.

Note that there is no CF code in any of these files except for a cfinclude statement. This ridiculously simple setup produces this error:

“Security: The requested template has been denied access to D:/inetpub/landpaths/_test_include.cfm.”

I take this to mean that CF10 has either not a) been configured correctly, or b) does not have read/write/modify/delete access to the directories and files in D:\inetpub\landpaths.

Either way, this is a hosting competency failure – not a CF code failure. Please fix it.
------------

I'm beyond frustrated with this. It's been two weeks of back-and-forths with Support, dealing with techs that can't even correctly absorb the problem, much less produce a solution. If there's anyone monitoring this thread, my support ticket is [07D-19724DDA-0303] and I'm currently stuck in support hell.